]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/dovecot/plugins/fts_xapian/default.nix
Configure mail (dovecot, postfix, spam checks)
[perso/Immae/Config/Nix.git] / pkgs / dovecot / plugins / fts_xapian / default.nix
diff --git a/pkgs/dovecot/plugins/fts_xapian/default.nix b/pkgs/dovecot/plugins/fts_xapian/default.nix
new file mode 100644 (file)
index 0000000..350a3ff
--- /dev/null
@@ -0,0 +1,14 @@
+{ stdenv, autoconf, automake, pkg-config, dovecot, libtool, xapian, icu, mylibs }:
+
+stdenv.mkDerivation (mylibs.fetchedGithub ./fts-xapian.json // rec {
+  buildInputs = [ dovecot autoconf automake libtool pkg-config xapian icu ];
+  preConfigure = ''
+    export PANDOC=false
+    autoreconf -vi
+    '';
+  configureFlags = [
+    "--with-dovecot=${dovecot}/lib/dovecot"
+    "--without-dovecot-install-dirs"
+    "--with-moduledir=$(out)/lib/dovecot"
+  ];
+})