]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/default.nix
Remove flaked modules
[perso/Immae/Config/Nix.git] / pkgs / default.nix
index 3aad1a2a841fbb31d616aecae37834602b0674f2..ff21a205819d97660bfc4f806c54afe2c3e09f49 100644 (file)
@@ -8,6 +8,7 @@ rec {
   myEnvironments = callPackage ../environments {};
   boinctui = callPackage ./boinctui {};
   cnagios = callPackage ./cnagios { inherit mylibs; };
+  commento = callPackage ./commento {};
   duply = callPackage ./duply {};
   flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
   genius = callPackage ./genius {};
@@ -16,11 +17,12 @@ rec {
   mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
   nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
   nagnu = callPackage ./nagnu { inherit mylibs; };
+  nb = callPackage ./nb {};
   note = callPackage ./note {};
   notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
   notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
   notmuch-vim = callPackage ./notmuch/notmuch-vim {};
-  openarc = callPackage ./openarc { inherit mylibs; };
+  openarc = (mylibs.flakeCompat ../flakes/openarc).default;
   opendmarc = callPackage ./opendmarc { libspf2 = callPackage ./opendmarc/libspf2.nix {}; };
   pg_activity = callPackage ./pg_activity { inherit mylibs; };
   pgloader = callPackage ./pgloader {};
@@ -50,8 +52,12 @@ rec {
   monitoring-plugins = callPackage ./monitoring-plugins {};
   naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
   naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
-
-  certbot = callPackage ./certbot {};
+  gearmand = callPackage ./gearmand {};
+  status_engine = {
+    module = callPackage ./status_engine/module.nix { inherit mylibs; };
+    worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
+    interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
+  };
 
   python3PackagesPlus = callPackage ./python-packages {
     python = python3;
@@ -65,4 +71,5 @@ rec {
   };
 
   fiche = callPackage ./fiche { inherit mylibs; };
+  zrepl = callPackage ./zrepl {};
 }