]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/default.nix
Remove flaked modules
[perso/Immae/Config/Nix.git] / pkgs / default.nix
index 14d3ed6f87c3213c9d4f6764fd05a20a4ae7fbb8..ff21a205819d97660bfc4f806c54afe2c3e09f49 100644 (file)
@@ -8,6 +8,7 @@ rec {
   myEnvironments = callPackage ../environments {};
   boinctui = callPackage ./boinctui {};
   cnagios = callPackage ./cnagios { inherit mylibs; };
+  commento = callPackage ./commento {};
   duply = callPackage ./duply {};
   flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
   genius = callPackage ./genius {};
@@ -16,11 +17,12 @@ rec {
   mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
   nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
   nagnu = callPackage ./nagnu { inherit mylibs; };
+  nb = callPackage ./nb {};
   note = callPackage ./note {};
   notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
   notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
   notmuch-vim = callPackage ./notmuch/notmuch-vim {};
-  openarc = callPackage ./openarc { inherit mylibs; };
+  openarc = (mylibs.flakeCompat ../flakes/openarc).default;
   opendmarc = callPackage ./opendmarc { libspf2 = callPackage ./opendmarc/libspf2.nix {}; };
   pg_activity = callPackage ./pg_activity { inherit mylibs; };
   pgloader = callPackage ./pgloader {};
@@ -50,9 +52,12 @@ rec {
   monitoring-plugins = callPackage ./monitoring-plugins {};
   naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
   naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
-
-  simp_le_0_17 = callPackage ./simp_le {};
-  certbot = callPackage ./certbot {};
+  gearmand = callPackage ./gearmand {};
+  status_engine = {
+    module = callPackage ./status_engine/module.nix { inherit mylibs; };
+    worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
+    interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
+  };
 
   python3PackagesPlus = callPackage ./python-packages {
     python = python3;
@@ -64,13 +69,7 @@ rec {
   dovecot_fts-xapian = callPackage ./dovecot/plugins/fts_xapian {
     inherit mylibs;
   };
-  monero_0_15_0_0 = (import (builtins.fetchTarball {
-    name = "nixos-19.09";
-    url = "https://releases.nixos.org/nixos/19.09/nixos-19.09.2145.c2c5dcc00b0/nixexprs.tar.xz";
-    sha256 = "0dh8qc3lzrba5mxxxh57i1374wc7ha3c30h7wsmj5zr7bhc5zm4p";
-  }) {}).monero;
-
-  niv = (import sources.niv {}).niv;
 
   fiche = callPackage ./fiche { inherit mylibs; };
+  zrepl = callPackage ./zrepl {};
 }