]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/default.nix
Add new tools
[perso/Immae/Config/Nix.git] / pkgs / default.nix
index ef6199c7f101e7556772c1e310d661e734d7831c..b260f97335f6349b0f910d79a19b7608dd5f3fbf 100644 (file)
@@ -8,6 +8,7 @@ rec {
   myEnvironments = callPackage ../environments {};
   boinctui = callPackage ./boinctui {};
   cnagios = callPackage ./cnagios { inherit mylibs; };
+  commento = callPackage ./commento {};
   duply = callPackage ./duply {};
   flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
   genius = callPackage ./genius {};
@@ -16,6 +17,7 @@ rec {
   mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
   nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
   nagnu = callPackage ./nagnu { inherit mylibs; };
+  nb = callPackage ./nb {};
   note = callPackage ./note {};
   notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
   notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
@@ -50,9 +52,12 @@ rec {
   monitoring-plugins = callPackage ./monitoring-plugins {};
   naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
   naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
-
-  simp_le_0_17 = callPackage ./simp_le {};
-  certbot = callPackage ./certbot {};
+  gearmand = callPackage ./gearmand {};
+  status_engine = {
+    module = callPackage ./status_engine/module.nix { inherit mylibs; };
+    worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
+    interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
+  };
 
   python3PackagesPlus = callPackage ./python-packages {
     python = python3;
@@ -65,7 +70,6 @@ rec {
     inherit mylibs;
   };
 
-  niv = (import sources.niv {}).niv;
-
   fiche = callPackage ./fiche { inherit mylibs; };
+  zrepl = callPackage ./zrepl {};
 }