]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - pkgs/default.nix
Migrate to proftpd
[perso/Immae/Config/Nix.git] / pkgs / default.nix
index 03fee4f99add7442192dc0e33c3c2cd3b1862777..5f5df82d11e6f0e20ee7f9d7a0ee32c3b6a14305 100644 (file)
@@ -9,7 +9,6 @@ rec {
   boinctui = callPackage ./boinctui {};
   cnagios = callPackage ./cnagios { inherit mylibs; };
   commento = callPackage ./commento {};
-  duply = callPackage ./duply {};
   flrn = callPackage ./flrn { inherit mylibs; slang = callPackage ./slang_1 {}; };
   genius = callPackage ./genius {};
   mtop = callPackage ./mtop {};
@@ -17,21 +16,21 @@ rec {
   mutt-ics = callPackage ./mutt-ics { inherit mylibs; };
   nagios-cli = callPackage ./nagios-cli { inherit mylibs; };
   nagnu = callPackage ./nagnu { inherit mylibs; };
+  nb = callPackage ./nb {};
   note = callPackage ./note {};
   notmuch-python2 = callPackage ./notmuch/notmuch-python { pythonPackages = python2Packages; };
   notmuch-python3 = callPackage ./notmuch/notmuch-python { pythonPackages = python3Packages; };
   notmuch-vim = callPackage ./notmuch/notmuch-vim {};
-  openarc = callPackage ./openarc { inherit mylibs; };
-  opendmarc = callPackage ./opendmarc { libspf2 = callPackage ./opendmarc/libspf2.nix {}; };
-  pg_activity = callPackage ./pg_activity { inherit mylibs; };
   pgloader = callPackage ./pgloader {};
   predixy = callPackage ./predixy { inherit mylibs; };
   rrsync_sudo = callPackage ./rrsync_sudo {};
-  telegram-cli = callPackage ./telegram-cli { inherit mylibs; };
+  signaldctl = callPackage ./signaldctl {};
   telegram-history-dump = callPackage ./telegram-history-dump { inherit mylibs; };
   telegramircd = callPackage ./telegramircd { inherit mylibs; telethon = callPackage ./telethon_sync {}; };
   terminal-velocity = callPackage ./terminal-velocity {};
   tiv = callPackage ./tiv {};
+  twins = callPackage ./twins {};
+  umami = callPackage ./umami {};
   unicodeDoc = callPackage ./unicode {};
 
   cardano = callPackage ./crypto/cardano { inherit mylibs; };
@@ -39,11 +38,8 @@ rec {
   iota-cli-app = callPackage ./crypto/iota-cli-app { inherit mylibs; };
   sia = callPackage ./crypto/sia {};
 
+  proftpd = callPackage ./proftpd {};
   pure-ftpd = callPackage ./pure-ftpd {};
-  mpd = (callPackage ./mpd_0_21 {}).mpd;
-  mpd-small = (callPackage ./mpd_0_21 {}).mpd-small;
-
-  bitlbee-mastodon = callPackage ./bitlbee-mastodon {};
 
   composerEnv = callPackage ./composer-env {};
   webapps = callPackage ./webapps { inherit mylibs composerEnv; };
@@ -51,6 +47,12 @@ rec {
   monitoring-plugins = callPackage ./monitoring-plugins {};
   naemon = callPackage ./naemon { inherit mylibs monitoring-plugins; };
   naemon-livestatus = callPackage ./naemon-livestatus { inherit mylibs naemon; };
+  gearmand = callPackage ./gearmand {};
+  status_engine = {
+    module = callPackage ./status_engine/module.nix { inherit mylibs; };
+    worker = callPackage ./status_engine/worker.nix { inherit mylibs composerEnv; };
+    interface = callPackage ./status_engine/interface.nix { inherit composerEnv; };
+  };
 
   python3PackagesPlus = callPackage ./python-packages {
     python = python3;
@@ -59,9 +61,4 @@ rec {
   dovecot_deleted-to-trash = callPackage ./dovecot/plugins/deleted_to_trash {
     inherit mylibs;
   };
-  dovecot_fts-xapian = callPackage ./dovecot/plugins/fts_xapian {
-    inherit mylibs;
-  };
-
-  fiche = callPackage ./fiche { inherit mylibs; };
 }