]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/tools/wallabag.nix
Configure mailer spool for tools
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / tools / wallabag.nix
index 4bda8089a5d3df7c196a25e4f5f71209478defaf..1c08bbf63baabfafc74a0ef7279e896b0bbffffd 100644 (file)
@@ -17,8 +17,8 @@ let
           database_socket: null
           database_charset: utf8
           domain_name: https://tools.immae.eu/wallabag
-          mailer_transport: smtp
-          mailer_host: mail.immae.eu
+          mailer_transport: sendmail
+          mailer_host: 127.0.0.1
           mailer_user: null
           mailer_password: null
           locale: fr
@@ -55,6 +55,10 @@ let
           ldap_email_attribute: mail
           ldap_name_attribute: cn
           ldap_enabled_attribute: null
+      services:
+          swiftmailer.mailer.default.transport:
+              class:     Swift_SendmailTransport
+              arguments: ['/run/wrappers/bin/sendmail -bs']
       '';
     webappDir = composerEnv.buildPackage rec {
       packages = {
@@ -172,7 +176,7 @@ let
 
         ; Needed to avoid clashes in browser cookies (same domain)
         php_value[session.name] = WallabagPHPSESSID
-        php_admin_value[open_basedir] = "${basedir}:/tmp"
+        php_admin_value[open_basedir] = "/run/wrappers/bin/sendmail:${basedir}:/tmp"
         php_value[max_execution_time] = 300
         '';
     };