]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/mastodon.nix
Remove useless relative symlinks
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / mastodon.nix
index ae2a3f609c179f587b3d57c8e942d4b2d9e461f3..ef7ef576dfc70367ba6e957b44ffa658277280f5 100644 (file)
@@ -90,6 +90,8 @@ let
 
     STREAMING_CLUSTER_NUM=1
 
+    RAILS_LOG_LEVEL=warn
+
     # LDAP authentication (optional)
     LDAP_ENABLED=true
     LDAP_HOST=ldap.immae.eu
@@ -117,7 +119,7 @@ let
         sed -i -e 's@^end$@  config.action_mailer.sendmail_settings = { location: ENV.fetch("SENDMAIL_LOCATION", "/usr/sbin/sendmail") }\nend@' config/environments/production.rb
         RAILS_ENV=production ${gems}/bin/rails assets:precompile
         rm -rf tmp/cache
-        ln -sf ../../../../../../../${varDir}/tmp/cache tmp
+        ln -sf ${varDir}/tmp/cache tmp
         '';
       buildInputs = [ gems gems.ruby pkgs.nodejs pkgs.yarn ];
     };