]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/mastodon.nix
Remove reference to ar coming from busybox sh
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / mastodon.nix
index 8650ee310b860e9e28e5d6780b60b421c69aa771..ae2a3f609c179f587b3d57c8e942d4b2d9e461f3 100644 (file)
@@ -42,7 +42,7 @@ let
             buildInputs = with pkgs; [ nodePackages.node-pre-gyp ];
           };
           node-sass = {
-            buildInputs = with pkgs; [ binutils libsass python ];
+            buildInputs = with pkgs; [ libsass python ];
             postInstall = let
               nodeHeaders = pkgs.fetchurl {
                 url = "https://nodejs.org/download/release/v${pkgs.nodejs.version}/node-v${pkgs.nodejs.version}-headers.tar.gz";
@@ -50,7 +50,6 @@ let
               };
             in
               ''
-                export AR=${pkgs.binutils.bintools}/bin/ar
                 node scripts/build.js --tarball=${nodeHeaders}
               '';
           };