]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/mastodon.nix
Remove mastodon build dependency on environment variables
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / mastodon.nix
index 3ee355227770a017c8d86a5f7be29aed7a9e6f22..67d4d48b01230351ce5b21f599b4f5c0789b44dc 100644 (file)
@@ -44,6 +44,9 @@ let
         yarnLock = "${info.src}/yarn.lock";
         yarnNix = ./yarn-packages.nix;
         pkgConfig = {
+          all = {
+            buildInputs = [ yarn2nixPackage.src ];
+          };
           uws = {
             postInstall = ''
               npx node-gyp rebuild > build_log.txt 2>&1 || true
@@ -106,14 +109,14 @@ let
     '';
   };
 
-    # FIXME: build machine will contain some passwords in the nix store
     railsRoot = stdenv.mkDerivation {
       name = "mastodon_immae";
       inherit mastodon;
       builder = writeText "build_mastodon_immae" ''
         source $stdenv/setup
         set -a
-        ${keys.mastodon.text}
+        SECRET_KEY_BASE=Dummy
+        OTP_SECRET=Dummy
         set +a
         cp -a $mastodon $out
         cd $out