]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/mastodon.nix
Adjust journald configuration and limit some verbose apps
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / mastodon.nix
index 8650ee310b860e9e28e5d6780b60b421c69aa771..5f0104c5da7a7b0e16f909ba1c80ee0b93bf2a57 100644 (file)
@@ -42,7 +42,7 @@ let
             buildInputs = with pkgs; [ nodePackages.node-pre-gyp ];
           };
           node-sass = {
-            buildInputs = with pkgs; [ binutils libsass python ];
+            buildInputs = with pkgs; [ libsass python ];
             postInstall = let
               nodeHeaders = pkgs.fetchurl {
                 url = "https://nodejs.org/download/release/v${pkgs.nodejs.version}/node-v${pkgs.nodejs.version}-headers.tar.gz";
@@ -50,7 +50,6 @@ let
               };
             in
               ''
-                export AR=${pkgs.binutils.bintools}/bin/ar
                 node scripts/build.js --tarball=${nodeHeaders}
               '';
           };
@@ -91,6 +90,8 @@ let
 
     STREAMING_CLUSTER_NUM=1
 
+    RAILS_LOG_LEVEL=warn
+
     # LDAP authentication (optional)
     LDAP_ENABLED=true
     LDAP_HOST=ldap.immae.eu