]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/mastodon/mastodon.nix
Add yarn2nix as dependency where needed to avoid garbage collection
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / mastodon / mastodon.nix
index 3ee355227770a017c8d86a5f7be29aed7a9e6f22..516cc5879ac04fba8ab901417ea120847315c54c 100644 (file)
@@ -44,6 +44,9 @@ let
         yarnLock = "${info.src}/yarn.lock";
         yarnNix = ./yarn-packages.nix;
         pkgConfig = {
+          all = {
+            buildInputs = [ yarn2nixPackage.src ];
+          };
           uws = {
             postInstall = ''
               npx node-gyp rebuild > build_log.txt 2>&1 || true