]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/git/default.nix
Replace myPhpfpm with correct overrides
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / git / default.nix
index e7dbd6f5ce074c368a727024a8aebe11ed0e6482..495c5eace0c7c6da9db8a8f4dc0d7a2b0be6fe98 100644 (file)
@@ -1,7 +1,6 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig, ... }:
 let
     mantisbt = pkgs.callPackage ./mantisbt.nix {
-      inherit (mylibs) fetchedGithub;
       inherit (pkgs.webapps) mantisbt_2 mantisbt_2-plugins;
       env = myconfig.env.tools.mantisbt;
     };
@@ -14,10 +13,8 @@ in {
   };
 
   config = lib.mkIf cfg.enable {
-    security.acme.certs."eldiron".extraDomains."git.immae.eu" = null;
-
-    mySecrets.keys = mantisbt.keys;
-    services.myWebsites.tools.modules =
+    secrets.keys = mantisbt.keys;
+    services.websites.tools.modules =
       gitweb.apache.modules ++
       mantisbt.apache.modules;
     system.extraSystemBuilderCmds = ''
@@ -26,8 +23,9 @@ in {
       ln -s ${mantisbt.webRoot} $out/webapps/${mantisbt.apache.webappName}
       '';
 
-    services.myWebsites.tools.vhostConfs.git = {
+    services.websites.tools.vhostConfs.git = {
       certName    = "eldiron";
+      addToCerts  = true;
       hosts       = ["git.immae.eu" ];
       root        = gitweb.apache.root;
       extraConfig = [
@@ -40,7 +38,7 @@ in {
           ''
       ];
     };
-    services.myPhpfpm.poolConfigs = {
+    services.phpfpm.poolConfigs = {
       mantisbt = mantisbt.phpFpm.pool;
     };
   };