]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/ether/etherpad_lite.nix
Move etherpad and mediagoblin keys to secure location
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / ether / etherpad_lite.nix
index 02071f1020472f92f0780ba05a99f3b0fb62e18f..bc622625b1b702f4154d5432780513111799d11a 100644 (file)
@@ -30,106 +30,110 @@ let
     "ep_subscript_and_superscript"
     "ep_timesliderdiff"
     ];
-  config =
-    # Make sure we’re not rebuilding whole libreoffice just because of a
-    # dependency
-    let libreoffice = (import <nixpkgs> {}).libreoffice-fresh;
-    in
-    writeText "settings.json" ''
-      {
-        "title": "Etherpad",
-        "favicon": "favicon.ico",
+  keys.tools-etherpad = {
+    destDir = "/run/keys/webapps";
+    permissions = "0400";
+    text =
+      # Make sure we’re not rebuilding whole libreoffice just because of a
+      # dependency
+      let libreoffice = (import <nixpkgs> {}).libreoffice-fresh;
+      in
+      ''
+        {
+          "title": "Etherpad",
+          "favicon": "favicon.ico",
 
-        "ip": "127.0.0.1",
-        "port" : ${env.listenPort},
-        "showSettingsInAdminPage" : false,
-        "dbType" : "postgres",
-        "dbSettings" : {
-          "user"    : "${env.postgresql.user}",
-          "host"    : "${env.postgresql.socket}",
-          "password": "${env.postgresql.password}",
-          "database": "${env.postgresql.database}",
-          "charset" : "utf8mb4"
-        },
+          "ip": "127.0.0.1",
+          "port" : ${env.listenPort},
+          "showSettingsInAdminPage" : false,
+          "dbType" : "postgres",
+          "dbSettings" : {
+            "user"    : "${env.postgresql.user}",
+            "host"    : "${env.postgresql.socket}",
+            "password": "${env.postgresql.password}",
+            "database": "${env.postgresql.database}",
+            "charset" : "utf8mb4"
+          },
 
-        "defaultPadText" : "Welcome to Etherpad!\n\nThis pad text is synchronized as you type, so that everyone viewing this page sees the same text. This allows you to collaborate seamlessly on documents!\n\nGet involved with Etherpad at http:\/\/etherpad.org\n",
-        "padOptions": {
-          "noColors": false,
-          "showControls": true,
-          "showChat": true,
-          "showLineNumbers": true,
-          "useMonospaceFont": false,
-          "userName": false,
-          "userColor": false,
-          "rtl": false,
-          "alwaysShowChat": false,
-          "chatAndUsers": false,
-          "lang": "en-gb"
-        },
+          "defaultPadText" : "Welcome to Etherpad!\n\nThis pad text is synchronized as you type, so that everyone viewing this page sees the same text. This allows you to collaborate seamlessly on documents!\n\nGet involved with Etherpad at http:\/\/etherpad.org\n",
+          "padOptions": {
+            "noColors": false,
+            "showControls": true,
+            "showChat": true,
+            "showLineNumbers": true,
+            "useMonospaceFont": false,
+            "userName": false,
+            "userColor": false,
+            "rtl": false,
+            "alwaysShowChat": false,
+            "chatAndUsers": false,
+            "lang": "en-gb"
+          },
 
-        "suppressErrorsInPadText" : false,
-        "requireSession" : false,
-        "editOnly" : false,
-        "sessionNoPassword" : false,
-        "minify" : true,
-        "maxAge" : 21600,
-        "abiword" : null,
-        "soffice" : "${libreoffice}/bin/soffice",
-        "tidyHtml" : "${pkgs.html-tidy}/bin/tidy",
-        "allowUnknownFileEnds" : true,
-        "requireAuthentication" : false,
-        "requireAuthorization" : false,
-        "trustProxy" : false,
-        "disableIPlogging" : false,
-        "automaticReconnectionTimeout" : 0,
-        "scrollWhenFocusLineIsOutOfViewport": {
-          "percentage": {
-            "editionAboveViewport": 0,
-            "editionBelowViewport": 0
+          "suppressErrorsInPadText" : false,
+          "requireSession" : false,
+          "editOnly" : false,
+          "sessionNoPassword" : false,
+          "minify" : true,
+          "maxAge" : 21600,
+          "abiword" : null,
+          "soffice" : "${libreoffice}/bin/soffice",
+          "tidyHtml" : "${pkgs.html-tidy}/bin/tidy",
+          "allowUnknownFileEnds" : true,
+          "requireAuthentication" : false,
+          "requireAuthorization" : false,
+          "trustProxy" : false,
+          "disableIPlogging" : false,
+          "automaticReconnectionTimeout" : 0,
+          "scrollWhenFocusLineIsOutOfViewport": {
+            "percentage": {
+              "editionAboveViewport": 0,
+              "editionBelowViewport": 0
+            },
+            "duration": 0,
+            "scrollWhenCaretIsInTheLastLineOfViewport": false,
+            "percentageToScrollWhenUserPressesArrowUp": 0
           },
-          "duration": 0,
-          "scrollWhenCaretIsInTheLastLineOfViewport": false,
-          "percentageToScrollWhenUserPressesArrowUp": 0
-        },
-        "users": {
-          "ldapauth": {
-            "url": "ldaps://${env.ldap.host}",
-            "accountBase": "${env.ldap.base}",
-            "accountPattern": "(&(memberOf=cn=users,cn=etherpad,ou=services,dc=immae,dc=eu)(uid={{username}}))",
-            "displayNameAttribute": "cn",
-            "searchDN": "cn=etherpad,ou=services,dc=immae,dc=eu",
-            "searchPWD": "${env.ldap.password}",
-            "groupSearchBase": "${env.ldap.base}",
-            "groupAttribute": "member",
-            "groupAttributeIsDN": true,
-            "searchScope": "sub",
-            "groupSearch": "(memberOf=cn=groups,cn=etherpad,ou=services,dc=immae,dc=eu)",
-            "anonymousReadonly": false
-          }
-        },
-        "socketTransportProtocols" : ["xhr-polling", "jsonp-polling", "htmlfile"],
-        "loadTest": false,
-        "indentationOnNewLine": false,
-        "toolbar": {
-          "left": [
-            ["bold", "italic", "underline", "strikethrough"],
-            ["orderedlist", "unorderedlist", "indent", "outdent"],
-            ["undo", "redo"],
-            ["clearauthorship"]
-          ],
-          "right": [
-            ["importexport", "timeslider", "savedrevision"],
-            ["settings", "embed"],
-            ["showusers"]
-          ],
-          "timeslider": [
-            ["timeslider_export", "timeslider_returnToPad"]
-          ]
-        },
-        "loglevel": "INFO",
-        "logconfig" : { "appenders": [ { "type": "console" } ] }
-      }
-    '';
+          "users": {
+            "ldapauth": {
+              "url": "ldaps://${env.ldap.host}",
+              "accountBase": "${env.ldap.base}",
+              "accountPattern": "(&(memberOf=cn=users,cn=etherpad,ou=services,dc=immae,dc=eu)(uid={{username}}))",
+              "displayNameAttribute": "cn",
+              "searchDN": "cn=etherpad,ou=services,dc=immae,dc=eu",
+              "searchPWD": "${env.ldap.password}",
+              "groupSearchBase": "${env.ldap.base}",
+              "groupAttribute": "member",
+              "groupAttributeIsDN": true,
+              "searchScope": "sub",
+              "groupSearch": "(memberOf=cn=groups,cn=etherpad,ou=services,dc=immae,dc=eu)",
+              "anonymousReadonly": false
+            }
+          },
+          "socketTransportProtocols" : ["xhr-polling", "jsonp-polling", "htmlfile"],
+          "loadTest": false,
+          "indentationOnNewLine": false,
+          "toolbar": {
+            "left": [
+              ["bold", "italic", "underline", "strikethrough"],
+              ["orderedlist", "unorderedlist", "indent", "outdent"],
+              ["undo", "redo"],
+              ["clearauthorship"]
+            ],
+            "right": [
+              ["importexport", "timeslider", "savedrevision"],
+              ["settings", "embed"],
+              ["showusers"]
+            ],
+            "timeslider": [
+              ["timeslider_export", "timeslider_returnToPad"]
+            ]
+          },
+          "loglevel": "INFO",
+          "logconfig" : { "appenders": [ { "type": "console" } ] }
+        }
+      '';
+  };
   webappDir = stdenv.mkDerivation (fetchedGithub ./etherpad-lite.json // rec {
     __noChroot = true;
     patches = [ ./libreoffice_patch.diff ];
@@ -179,5 +183,5 @@ let
   });
 in
   {
-    inherit webappDir config listenPort;
+    inherit webappDir keys listenPort;
   }