]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/tools/cloud/default.nix
Add cron background job for nextcloud
[perso/Immae/Config/Nix.git] / nixops / modules / websites / tools / cloud / default.nix
index 0c6d13d376196f863fac11e4457bbf7c04e61d49..f014776c88efaa32d083ed6b7a0b3610e5a33074 100644 (file)
@@ -43,5 +43,14 @@ in {
       poolConfigs.nextcloud = nextcloud.phpFpm.pool;
     };
 
+    services.cron = {
+      enable = true;
+      systemCronJobs = [
+        ''
+          LOCALE_ARCHIVE=/run/current-system/sw/lib/locale/locale-archive
+          */15 * * * * wwwrun ${pkgs.php}/bin/php -f ${nextcloud.webRoot}/cron.php
+        ''
+      ];
+    };
   };
 }