]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/piedsjaloux/default.nix
Move integration websites to use stable web directory
[perso/Immae/Config/Nix.git] / nixops / modules / websites / piedsjaloux / default.nix
index f1bb76039b3c74791ba2f4f88097a72a31614c91..584e936fc9de43298f3c9eb37909f67cf5d7001b 100644 (file)
@@ -42,6 +42,10 @@ in {
 
       services.myPhpfpm.poolConfigs.piedsjaloux_prod = piedsjaloux_prod.phpFpm.pool;
       system.activationScripts.piedsjaloux_prod = piedsjaloux_prod.activationScript;
+      system.extraSystemBuilderCmds = ''
+        mkdir -p $out/webapps
+        ln -s ${piedsjaloux_prod.webRoot} $out/webapps/${piedsjaloux_prod.apache.webappName}
+        '';
       services.myWebsites.production.modules = piedsjaloux_prod.apache.modules;
       services.myWebsites.production.vhostConfs.piedsjaloux = {
         certName    = "piedsjaloux";
@@ -54,11 +58,15 @@ in {
       security.acme.certs."eldiron".extraDomains."piedsjaloux.immae.eu" = null;
       services.myPhpfpm.poolConfigs.piedsjaloux_dev = piedsjaloux_dev.phpFpm.pool;
       system.activationScripts.piedsjaloux_dev = piedsjaloux_dev.activationScript;
+      system.extraSystemBuilderCmds = ''
+        mkdir -p $out/webapps
+        ln -s ${piedsjaloux_dev.webRoot} $out/webapps/${piedsjaloux_dev.apache.webappName}
+        '';
       services.myWebsites.integration.modules = piedsjaloux_dev.apache.modules;
       services.myWebsites.integration.vhostConfs.piedsjaloux = {
         certName    = "eldiron";
         hosts       = [ "piedsjaloux.immae.eu" ];
-        root        = piedsjaloux_dev.webRoot;
+        root        = piedsjaloux_dev.apache.root;
         extraConfig = [ piedsjaloux_dev.apache.vhostConf ];
       };
     })