]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/piedsjaloux/default.nix
Move Ludivine Piedsjaloux and Florian's websites passwords to a secure location
[perso/Immae/Config/Nix.git] / nixops / modules / websites / piedsjaloux / default.nix
index 584e936fc9de43298f3c9eb37909f67cf5d7001b..1c6864c861ded6deb3b95133376bbfe7069ec05f 100644 (file)
@@ -25,6 +25,7 @@ in {
 
   config = lib.mkMerge [
     (lib.mkIf cfg.production.enable {
+      deployment.keys = piedsjaloux_prod.keys;
       services.myWebsites.commons.stats.enable = true;
       services.myWebsites.commons.stats.sites = [
         {
@@ -50,11 +51,12 @@ in {
       services.myWebsites.production.vhostConfs.piedsjaloux = {
         certName    = "piedsjaloux";
         hosts       = [ "piedsjaloux.fr" "www.piedsjaloux.fr" ];
-        root        = piedsjaloux_prod.webRoot;
+        root        = piedsjaloux_prod.apache.root;
         extraConfig = [ piedsjaloux_prod.apache.vhostConf ];
       };
     })
     (lib.mkIf cfg.integration.enable {
+      deployment.keys = piedsjaloux_dev.keys;
       security.acme.certs."eldiron".extraDomains."piedsjaloux.immae.eu" = null;
       services.myPhpfpm.poolConfigs.piedsjaloux_dev = piedsjaloux_dev.phpFpm.pool;
       system.activationScripts.piedsjaloux_dev = piedsjaloux_dev.activationScript;