]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/ftp/temp.nix
Start moving websites configuration to modules
[perso/Immae/Config/Nix.git] / nixops / modules / websites / ftp / temp.nix
index 10331217b9a828f4ee2d9b034b7de132bc925256..bdd80c0d83e84dbd35302d85544cd17ca4af5a58 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig,  ... }:
 let
     cfg = config.services.myWebsites.Temp;
     varDir = "/var/lib/ftp/temp.immae.eu";
@@ -13,14 +13,14 @@ in {
   config = lib.mkIf cfg.production.enable {
     security.acme.certs."eldiron".extraDomains."temp.immae.eu" = null;
 
-    services.myWebsites.production.modules = [ "headers" ];
-    services.myWebsites.production.vhostConfs.temp = {
+    services.websites.production.modules = [ "headers" ];
+    services.websites.production.vhostConfs.temp = {
       certName    = "eldiron";
       hosts       = [ "temp.immae.eu" ];
       root        = varDir;
       extraConfig = [
         ''
-        Use Apaxy "${varDir}" "title"
+        Use Apaxy "${varDir}" "title .duplicity-ignore"
         <FilesMatch ".+">
           Header set Content-Disposition attachment
         </FilesMatch>