]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/ftp/immae.nix
Start moving websites configuration to modules
[perso/Immae/Config/Nix.git] / nixops / modules / websites / ftp / immae.nix
index 64e6a59a5ae29705d9e5318c9f852e1eef3a9a33..e188d95d8787e7f255e64d67e165ec33bae9d8d1 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, myconfig, mylibs, ... }:
+{ lib, pkgs, config, myconfig,  ... }:
 let
     cfg = config.services.myWebsites.Immae;
     varDir = "/var/lib/ftp/immae";
@@ -10,18 +10,8 @@ in {
     };
   };
 
-  imports = [
-    ../commons/stats.nix
-  ];
-
   config = lib.mkIf cfg.production.enable {
-    services.myWebsites.commons.stats.enable = true;
-    services.myWebsites.commons.stats.sites = [
-      {
-        name = "www.immae.eu";
-        conf = ./immae_goaccess.conf;
-      }
-    ];
+    services.webstats.sites = [ { name = "www.immae.eu"; } ];
 
     security.acme.certs."eldiron".extraDomains."www.immae.eu" = null;
 
@@ -38,8 +28,8 @@ in {
 
       php_admin_value[open_basedir] = "${varDir}:/tmp"
       '';
-    services.myWebsites.production.modules = [ "proxy_fcgi" ];
-    services.myWebsites.production.vhostConfs.immae = {
+    services.websites.production.modules = [ "proxy_fcgi" ];
+    services.websites.production.vhostConfs.immae = {
       certName    = "eldiron";
       hosts       = [ "www.immae.eu" ];
       root        = varDir;
@@ -68,7 +58,7 @@ in {
 
     security.acme.certs."eldiron".extraDomains."bouya.org" = null;
     security.acme.certs."eldiron".extraDomains."www.bouya.org" = null;
-    services.myWebsites.production.vhostConfs.bouya = {
+    services.websites.production.vhostConfs.bouya = {
       certName    = "eldiron";
       hosts       = [ "bouya.org" "www.bouya.org" ];
       root        = null;