]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/websites/ftp/immae.nix
Make goaccess a template
[perso/Immae/Config/Nix.git] / nixops / modules / websites / ftp / immae.nix
index 6acfe44c15d2d8a483fe4aebdc5d2d06a84b2dd2..2ecca1fe764a8c44ce1f03f474c990ba32b1fdeb 100644 (file)
@@ -17,10 +17,7 @@ in {
   config = lib.mkIf cfg.production.enable {
     services.myWebsites.commons.stats.enable = true;
     services.myWebsites.commons.stats.sites = [
-      {
-        name = "www.immae.eu";
-        conf = ./immae_goaccess.conf;
-      }
+      { name = "www.immae.eu"; }
     ];
 
     security.acme.certs."eldiron".extraDomains."www.immae.eu" = null;
@@ -65,5 +62,16 @@ in {
         ''
       ];
     };
+
+    security.acme.certs."eldiron".extraDomains."bouya.org" = null;
+    security.acme.certs."eldiron".extraDomains."www.bouya.org" = null;
+    services.myWebsites.production.vhostConfs.bouya = {
+      certName    = "eldiron";
+      hosts       = [ "bouya.org" "www.bouya.org" ];
+      root        = null;
+      extraConfig = [ ''
+        RedirectMatch 301 ^/((?!\.well-known.*$).*)$ https://www.normalesup.org/~bouya/
+        '' ];
+    };
   };
 }