]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/modules/databases/default.nix
Add cron backup for LDAP
[perso/Immae/Config/Nix.git] / nixops / modules / databases / default.nix
index bbacded26d9aa2f8409792069f44125e05af3717..32001810475af4b5e71f8276b11dc972ccd67283 100644 (file)
@@ -2,6 +2,9 @@
 let
     cfg = config.services.myDatabases;
 in {
+  imports = [
+    ./openldap.nix
+  ];
   options.services.myDatabases = {
     enable = lib.mkEnableOption "my databases service";
     postgresql = {
@@ -124,8 +127,9 @@ in {
       authentication = ''
         local  all     postgres                                ident
         local  all     all                                     md5
-        hostssl        discourse       discourse       all                             md5
-        hostssl        all     all             all                     pam
+        hostssl        all     all     188.165.209.148/32              md5
+        hostssl        all     all     178.33.252.96/32                md5
+        hostssl        all     all     all                             pam
         hostssl        replication     backup-1        2001:41d0:302:1100::9:e5a9/128  pam pamservice=postgresql_replication
         hostssl        replication     backup-1        54.37.151.137/32                pam pamservice=postgresql_replication
       '';
@@ -201,5 +205,6 @@ in {
       mkdir -p $(dirname ${myconfig.env.databases.redis.socket})
       chown redis $(dirname ${myconfig.env.databases.redis.socket})
     '';
+
   };
 }