]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/eldiron.nix
Use password store to store environment
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
index 289333534a4fbfab0facc833c1214bb9c84f73e1..ecc65cc3f0082b3af970f4df7658910078b21d88 100644 (file)
@@ -1,3 +1,4 @@
+{ environment ? ./environment.nix }:
 {
   network = {
     description = "Immae's network";
@@ -10,7 +11,7 @@
     _module.args = {
       mylibs = import ../libs.nix;
       myconfig = {
-        env = import ./environment.nix;
+        env = import environment;
         ips = {
           main = "176.9.151.89";
           production = "176.9.151.154";
@@ -93,6 +94,8 @@
 
     services.cron = {
       enable = true;
+      # Doesn't work, need to be a user
+      mailto = "cron+eldiron@immae.eu";
       systemCronJobs = [
         ''
           # The star after /var/lib/* avoids deleting all folders in case of problem