]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/eldiron.nix
Add state version
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
index cad4e7545fcfd12d3bf6ddb7b256a817951025d3..8dc8c4d8273a8e09e624fc26e64d51f403f9a460 100644 (file)
@@ -10,6 +10,7 @@
   {
     _module.args = {
       mylibs = import ../libs.nix;
+      mypkgs = import ../default.nix;
       myconfig = {
         env = import environment;
         ips = {
@@ -24,6 +25,7 @@
       ./modules/certificates.nix
       ./modules/gitolite
       ./modules/databases
+      ./modules/mpd
       ./modules/websites
       ./modules/mail
       ./modules/ftp
     services.myWebsites.tools.enable = true;
     services.pure-ftpd.enable = true;
 
+    services.journald.extraConfig = ''
+      MaxLevelStore="warning"
+      MaxRetentionSec="1year"
+      '';
     networking = {
       firewall = {
         enable = true;
         ''
       ];
     };
+
+    # This value determines the NixOS release with which your system is
+    # to be compatible, in order to avoid breaking some software such as
+    # database servers. You should change this only after NixOS release
+    # notes say you should.
+    system.stateVersion = "18.09"; # Did you read the comment?
   };
 }