]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - nixops/eldiron.nix
Add state version
[perso/Immae/Config/Nix.git] / nixops / eldiron.nix
index b54702e68e71d2460c35174a97150aad1aae0083..8dc8c4d8273a8e09e624fc26e64d51f403f9a460 100644 (file)
@@ -1,3 +1,4 @@
+{ environment ? ./environment.nix }:
 {
   network = {
     description = "Immae's network";
@@ -9,8 +10,9 @@
   {
     _module.args = {
       mylibs = import ../libs.nix;
+      mypkgs = import ../default.nix;
       myconfig = {
-        env = import ./environment.nix;
+        env = import environment;
         ips = {
           main = "176.9.151.89";
           production = "176.9.151.154";
       ./modules/certificates.nix
       ./modules/gitolite
       ./modules/databases
+      ./modules/mpd
       ./modules/websites
       ./modules/mail
+      ./modules/ftp
     ];
     services.myGitolite.enable = true;
     services.myDatabases.enable = true;
     services.myWebsites.production.enable = true;
     services.myWebsites.integration.enable = true;
     services.myWebsites.tools.enable = true;
+    services.pure-ftpd.enable = true;
 
+    services.journald.extraConfig = ''
+      MaxLevelStore="warning"
+      MaxRetentionSec="1year"
+      '';
     networking = {
       firewall = {
         enable = true;
       systemCronJobs = [
         ''
           # The star after /var/lib/* avoids deleting all folders in case of problem
-          0 3,9,15,21 * * * root rsync -e "ssh -i /root/.ssh/id_charon_vpn" -aAXvz --delete --numeric-ids --super --rsync-path="sudo rsync" /var/lib/* immae@immae.eu:
+          0 3,9,15,21 * * * root rsync -e "ssh -i /root/.ssh/id_charon_vpn" -aAXvz --delete --numeric-ids --super --rsync-path="sudo rsync" /var/lib/* immae@immae.eu: > /dev/null
         ''
       ];
     };
+
+    # This value determines the NixOS release with which your system is
+    # to be compatible, in order to avoid breaking some software such as
+    # database servers. You should change this only after NixOS release
+    # notes say you should.
+    system.stateVersion = "18.09"; # Did you read the comment?
   };
 }