]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/websites/php-application.nix
Remove webappdirs
[perso/Immae/Config/Nix.git] / modules / websites / php-application.nix
index 23e2b233581c3b92cc252360e220155f89fdb537..3a43a45e4bdd74e41dc59ca4322f8d3ac8297ee7 100644 (file)
@@ -110,13 +110,6 @@ in
               Path to application root
               '';
           };
-          webappName = mkOption {
-            type = nullOr str;
-            default = null;
-            description = ''
-              Alias name for the app, to be used in services.websites.webappDirs
-              '';
-          };
           webRoot = mkOption {
             type = nullOr path;
             description = ''
@@ -152,14 +145,6 @@ in
         Full paths to listen for php
         '';
     };
-    services.phpApplication.webappDirs = mkOption {
-      type = attrsOf path;
-      default = attrsets.filterAttrs (n: v: builtins.hasAttr n cfg.apps) config.services.websites.webappDirsPaths;
-      readOnly = true;
-      description = ''
-        Stable name webapp dirs for httpd
-        '';
-    };
   };
 
   config = {
@@ -186,10 +171,6 @@ in
       }
     ) cfg.apps;
 
-    services.websites.webappDirs = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
-      (if icfg.webappName == null then name else icfg.webappName) icfg.webRoot
-    ) (attrsets.filterAttrs (n: v: !isNull v.webRoot) cfg.apps);
-
     services.filesWatcher = attrsets.mapAttrs' (name: icfg: attrsets.nameValuePair
       "phpfpm-${name}" {
         restart = true;