]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/webapps/webstats/default.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / webapps / webstats / default.nix
index 3650e1e713c698a59d3349c388f84d5467c48b10..fe5f068d410345e1f84a20e8c0d65474989260ec 100644 (file)
@@ -1,4 +1,4 @@
-{ lib, pkgs, config, mylibs, ... }:
+{ lib, pkgs, config, ... }:
 let
   name = "goaccess";
   cfg = config.services.webstats;
@@ -23,7 +23,7 @@ in {
               '';
           };
           name = lib.mkOption {
-            type = lib.types.string;
+            type = lib.types.str;
             description  = ''
               Domain name. Corresponds to the Apache file name and the
               folder name in which the state will be saved.
@@ -37,6 +37,9 @@ in {
   };
 
   config = lib.mkIf (builtins.length cfg.sites > 0) {
+    services.duplyBackup.profiles.goaccess = {
+      rootDir = cfg.dataDir;
+    };
     users.users.root.packages = [
       pkgs.goaccess
     ];