]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/webapps/mastodon.nix
Put services in slices in systemd
[perso/Immae/Config/Nix.git] / modules / webapps / mastodon.nix
index cd550c0e64cf75d81dc5694489e033df88e1597c..2f5a8e392027016791d7d3544b27d1ccbbb174a6 100644 (file)
@@ -111,6 +111,10 @@ in
       };
     };
 
+    systemd.slices.mastodon = {
+      description = "Mastodon slice";
+    };
+
     systemd.services.mastodon-streaming = {
       description = "Mastodon Streaming";
       wantedBy = [ "multi-user.target" ];
@@ -137,6 +141,7 @@ in
       '';
 
       serviceConfig = {
+        Slice = "mastodon.slice";
         User = cfg.user;
         EnvironmentFile = cfg.configFile;
         PrivateTmp = true;
@@ -177,6 +182,7 @@ in
         exec ./bin/tootctl cache clear
         '';
       serviceConfig = {
+        Slice = "mastodon.slice";
         User = cfg.user;
         EnvironmentFile = cfg.configFile;
         PrivateTmp = true;
@@ -239,6 +245,7 @@ in
       '';
 
       serviceConfig = {
+        Slice = "mastodon.slice";
         User = cfg.user;
         EnvironmentFile = cfg.configFile;
         PrivateTmp = true;