]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/rsync_backup/default.nix
Add timezone for Denise
[perso/Immae/Config/Nix.git] / modules / rsync_backup / default.nix
index 55b32bfa7574afe100d2b87fbee5a5491ac19948..ff84fe3fbb60ae98686a21b3854e244c17f01d00 100644 (file)
@@ -41,6 +41,13 @@ let
           Number of backups to keep
           '';
       };
+      check_command = lib.mkOption {
+        type = lib.types.str;
+        default = "backup";
+        description = ''
+          command to check if backup needs to be done
+        '';
+      };
       login = lib.mkOption {
         type = lib.types.str;
         description = ''
@@ -128,7 +135,7 @@ let
           -o CheckHostIP=no \
           -p $PORT \
           -i ${ssh_key} \
-          $DEST backup; then
+          $DEST ${profile.check_command}; then
         echo "Fichier de verrouillage backup sur $DEST ou impossible de se connecter" >&2
         skip=$DEST
       fi