]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/ympd.nix
Squash changes containing private information
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / ympd.nix
diff --git a/modules/private/websites/tools/tools/ympd.nix b/modules/private/websites/tools/tools/ympd.nix
deleted file mode 100644 (file)
index 531b1a9..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-{ env }:
-let
-  ympd = rec {
-    config = {
-      webPort = "localhost:${toString env.listenPort}";
-      host = env.mpd.host;
-      port = env.mpd.port;
-    };
-    apache = {
-      modules = [
-        "proxy_wstunnel"
-        ];
-      vhostConf = ''
-        <LocationMatch "^/mpd(?!/music.(mp3|ogg))">
-          Use LDAPConnect
-          Require ldap-group   cn=users,cn=mpd,ou=services,dc=immae,dc=eu
-        </LocationMatch>
-
-        RedirectMatch permanent "^/mpd$" "/mpd/"
-        <Location "/mpd/">
-          ProxyPass http://${config.webPort}/
-          ProxyPassReverse http://${config.webPort}/
-          ProxyPreserveHost on
-        </Location>
-        <Location "/mpd/ws">
-          ProxyPass ws://${config.webPort}/ws
-        </Location>
-        <Location "/mpd/music.mp3">
-          ProxyPass unix:///run/mpd/mp3.sock|http://tools.immae.eu/mpd/mp3
-          ProxyPassReverse unix:///run/mpd/mp3.sock|http://tools.immae.eu/mpd/mp3
-        </Location>
-        <Location "/mpd/music.ogg">
-          ProxyPass unix:///run/mpd/ogg.sock|http://tools.immae.eu/mpd/ogg
-          ProxyPassReverse unix:///run/mpd/ogg.sock|http://tools.immae.eu/mpd/ogg
-        </Location>
-      '';
-    };
-  };
-in
-  ympd