]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/wallabag.nix
Add phpFpm prestart script to lib
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / wallabag.nix
index d6e588285e19eaa4159d633237d04afdcca439ac..ba755e4d514fbc3636960f0f0e906f138a528e8c 100644 (file)
@@ -1,4 +1,4 @@
-{ env, wallabag }:
+{ env, wallabag, mylibs }:
 rec {
   varDir = "/var/lib/wallabag";
   keys = [{
@@ -110,20 +110,18 @@ rec {
       '';
   };
   phpFpm = rec {
-    preStart = ''
-      if [ ! -f "${varDir}/currentWebappDir" -o \
-          ! -f "${varDir}/currentKey" -o \
-          "${webappDir}" != "$(cat ${varDir}/currentWebappDir 2>/dev/null)" ] \
-          || ! sha512sum -c --status ${varDir}/currentKey; then
-        pushd ${webappDir} > /dev/null
-        /run/wrappers/bin/sudo -u wwwrun ./bin/console --env=prod cache:clear
-        rm -rf /var/lib/wallabag/var/cache/pro_
-        /run/wrappers/bin/sudo -u wwwrun ./bin/console --env=prod doctrine:migrations:migrate --no-interaction
-        popd > /dev/null
-        echo -n "${webappDir}" > ${varDir}/currentWebappDir
-        sha512sum /var/secrets/webapps/tools-wallabag > ${varDir}/currentKey
-      fi
-      '';
+    preStart = mylibs.phpFpmPreStart {
+      app = webappDir;
+      inherit varDir;
+      keyFiles = [
+        "/var/secrets/webapps/tools-wallabag"
+      ];
+      actions = [
+        "/run/wrappers/bin/sudo -u wwwrun ./bin/console --env=prod cache:clear"
+        "rm -rf /var/lib/wallabag/var/cache/pro_"
+        "/run/wrappers/bin/sudo -u wwwrun ./bin/console --env=prod doctrine:migrations:migrate --no-interaction"
+      ];
+    };
     serviceDeps = [ "postgresql.service" "openldap.service" ];
     basedir = builtins.concatStringsSep ":" [ webappDir "/var/secrets/webapps/tools-wallabag" varDir ];
     socket = "/var/run/phpfpm/wallabag.sock";