]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/wallabag.nix
Add backup module
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / wallabag.nix
index d6e588285e19eaa4159d633237d04afdcca439ac..8572d64ca02405b3e86f75e6a005ff1b03400f53 100644 (file)
@@ -1,5 +1,8 @@
-{ env, wallabag }:
+{ env, wallabag, mylibs }:
 rec {
+  backups = {
+    rootDir = varDir;
+  };
   varDir = "/var/lib/wallabag";
   keys = [{
     dest = "webapps/tools-wallabag";
@@ -123,7 +126,7 @@ rec {
         echo -n "${webappDir}" > ${varDir}/currentWebappDir
         sha512sum /var/secrets/webapps/tools-wallabag > ${varDir}/currentKey
       fi
-      '';
+    '';
     serviceDeps = [ "postgresql.service" "openldap.service" ];
     basedir = builtins.concatStringsSep ":" [ webappDir "/var/secrets/webapps/tools-wallabag" varDir ];
     socket = "/var/run/phpfpm/wallabag.sock";