]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/tools/ttrss.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / tools / ttrss.nix
index 598cc3a1168fbfa7ed13188deb52a80f9c365248..4a9b8ca46187d3b56a794a59a5a3165e3ea1517f 100644 (file)
@@ -73,14 +73,14 @@ rec {
         define('SMTP_FROM_ADDRESS', 'ttrss@tools.immae.eu');
         define('DIGEST_SUBJECT', '[tt-rss] New headlines for last 24 hours');
 
-        define('LDAP_AUTH_SERVER_URI', 'ldap://ldap.immae.eu:389/');
+        define('LDAP_AUTH_SERVER_URI', 'ldap://${env.ldap.host}:389/');
         define('LDAP_AUTH_USETLS', TRUE);
         define('LDAP_AUTH_ALLOW_UNTRUSTED_CERT', TRUE);
-        define('LDAP_AUTH_BASEDN', 'dc=immae,dc=eu');
+        define('LDAP_AUTH_BASEDN', '${env.ldap.base}');
         define('LDAP_AUTH_ANONYMOUSBEFOREBIND', FALSE);
-        define('LDAP_AUTH_SEARCHFILTER', '(&(memberOf=cn=users,cn=ttrss,ou=services,dc=immae,dc=eu)(|(cn=???)(uid=???)(&(uid:dn:=???)(ou=ttrss))))');
+        define('LDAP_AUTH_SEARCHFILTER', '${env.ldap.filter}');
 
-        define('LDAP_AUTH_BINDDN', 'cn=ttrss,ou=services,dc=immae,dc=eu');
+        define('LDAP_AUTH_BINDDN', '${env.ldap.dn}');
         define('LDAP_AUTH_BINDPW', '${env.ldap.password}');
         define('LDAP_AUTH_LOGIN_ATTRIB', 'immaeTtrssLogin');