]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/peertube/default.nix
Update nix unstable
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / peertube / default.nix
index 445030c792b343ba3eb7d1c3a987f28ce7e35184..d2cbe406e1ba1f6397a2ab7ec503b817f1fcd586 100644 (file)
@@ -15,7 +15,6 @@ in {
     services.peertube = {
       enable = true;
       configFile = "/var/secrets/webapps/tools-peertube";
-      package = pkgs.webapps.peertube.override { ldap = true; sendmail = true; light = "fr-FR"; };
     };
     users.users.peertube.extraGroups = [ "keys" ];
 
@@ -32,25 +31,6 @@ in {
           https: true
           hostname: 'peertube.immae.eu'
           port: 443
-        rates_limit:
-          api:
-            # 50 attempts in 10 seconds
-            window: 10 seconds
-            max: 50
-          login:
-            # 15 attempts in 5 min
-            window: 5 minutes
-            max: 15
-          signup:
-            # 2 attempts in 5 min (only succeeded attempts are taken into account)
-            window: 5 minutes
-            max: 2
-          ask_send_email:
-            # 3 attempts in 5 min
-            window: 5 minutes
-            max: 3
-        trust_proxy:
-          - 'loopback'
         database:
           hostname: '${env.postgresql.socket}'
           port: 5432
@@ -63,34 +43,10 @@ in {
           socket: '${env.redis.socket}'
           auth: null
           db: ${env.redis.db}
-        auth:
-          local:
-            enabled: true
-          ldap:
-            enabled: true
-            ldap_only: false
-            url: ldaps://${env.ldap.host}/${env.ldap.base}
-            bind_dn: ${env.ldap.dn}
-            bind_password: ${env.ldap.password}
-            base: ${env.ldap.base}
-            mail_entry: "mail"
-            user_filter: "${env.ldap.filter}"
         smtp:
           transport: sendmail
           sendmail: '/run/wrappers/bin/sendmail'
-          hostname: null
-          port: 465 # If you use StartTLS: 587
-          username: null
-          password: null
-          tls: true # If you use StartTLS: false
-          disable_starttls: false
-          ca_file: null # Used for self signed certificates
           from_address: 'peertube@tools.immae.eu'
-        email:
-          body:
-            signature: "PeerTube"
-          subject:
-            prefix: "[PeerTube]"
         storage:
           tmp: '${pcfg.dataDir}/storage/tmp/'
           avatars: '${pcfg.dataDir}/storage/avatars/'
@@ -104,134 +60,7 @@ in {
           captions: '${pcfg.dataDir}/storage/captions/'
           cache: '${pcfg.dataDir}/storage/cache/'
           plugins: '${pcfg.dataDir}/storage/plugins/'
-        log:
-          level: 'info'
-          rotation:
-            enabled : true # Enabled by default, if disabled make sure that 'storage.logs' is pointing to a folder handled by logrotate
-            maxFileSize: 12MB
-            maxFiles: 20
-          anonymizeIP: false
-        search:
-          remote_uri:
-            users: true
-            anonymous: false
-        trending:
-          videos:
-            interval_days: 7
-        redundancy:
-          videos:
-            check_interval: '1 hour' # How often you want to check new videos to cache
-            strategies: # Just uncomment strategies you want
-        csp:
-          enabled: false
-          report_only: true # CSP directives are still being tested, so disable the report only mode at your own risk!
-          report_uri:
-        tracker:
-          enabled: true
-          private: true
-          reject_too_many_announces: false
-        history:
-          videos:
-            max_age: -1
-        views:
-          videos:
-            remote:
-              max_age: -1
-        plugins:
-          index:
-            enabled: true
-            check_latest_versions_interval: '12 hours'
-            url: 'https://packages.joinpeertube.org'
-        # Following are saved in local-production.json
-        cache:
-          previews:
-            size: 500 # Max number of previews you want to cache
-          captions:
-            size: 500 # Max number of video captions/subtitles you want to cache
-        admin:
-          email: 'peertube@tools.immae.eu'
-        contact_form:
-          enabled: true
-        signup:
-          enabled: false
-          limit: 10
-          requires_email_verification: false
-          filters:
-            cidr:
-              whitelist: []
-              blacklist: []
-        user:
-          video_quota: -1
-          video_quota_daily: -1
-        transcoding:
-          enabled: false
-          allow_additional_extensions: true
-          allow_audio_files: true
-          threads: 1
-          resolutions:
-            0p: false
-            240p: false
-            360p: false
-            480p: true
-            720p: true
-            1080p: true
-            2160p: false
-          webtorrent:
-            enabled: true
-          hls:
-            enabled: false
-        import:
-          videos:
-            http:
-              enabled: true
-            torrent:
-              enabled: false
-        auto_blacklist:
-          videos:
-            of_users:
-              enabled: false
-        instance:
-          name: 'Immae’s PeerTube'
-          short_description: 'PeerTube, a federated (ActivityPub) video streaming platform using P2P (BitTorrent) directly in the web browser with WebTorrent and Angular.'
-          description: '''
-          terms: '''
-          code_of_conduct: '''
-          moderation_information: '''
-          creation_reason: '''
-          administrator: '''
-          maintenance_lifetime: '''
-          business_model: '''
-          hardware_information: '''
-          languages:
-          categories:
-          default_client_route: '/videos/trending'
-          is_nsfw: false
-          default_nsfw_policy: 'do_not_list'
-          customizations:
-            javascript: '''
-            css: '''
-          robots: |
-            User-agent: *
-            Disallow:
-          securitytxt:
-            "# If you would like to report a security issue\n# you may report it to:\nContact: https://github.com/Chocobozzz/PeerTube/blob/develop/SECURITY.md\nContact: mailto:"
-        services:
-          twitter:
-            username: '@_immae'
-            whitelisted: false
-        followers:
-          instance:
-            enabled: true
-            manual_approval: false
-        followings:
-          instance:
-            auto_follow_back:
-              enabled: false
-            auto_follow_index:
-              enabled: false
-              index_url: 'https://instances.joinpeertube.org'
-        theme:
-          default: 'default'
+          client_overrides: '${pcfg.dataDir}/storage/client-overrides/'
         '';
     }];