]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/mail/roundcubemail.nix
Use new withPlugin system
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / mail / roundcubemail.nix
index 6875bae54de653104fa901e8775147d5e3326b12..bb7dee9eba1e97072bc3100f3042220a0ae7c56f 100644 (file)
@@ -1,4 +1,4 @@
-{ env, roundcubemail, roundcubemail-plugins, roundcubemail-skins, apacheHttpd }:
+{ env, roundcubemail, apacheHttpd }:
 rec {
   varDir = "/var/lib/roundcubemail";
   activationScript = {
@@ -75,8 +75,7 @@ rec {
         $config['mime_types'] = '${apacheHttpd}/conf/mime.types';
     '';
   }];
-  webRoot = (roundcubemail.override { roundcube_config = "/var/secrets/webapps/tools-roundcube"; }).withPlugins
-    (builtins.attrValues roundcubemail-plugins) (builtins.attrValues roundcubemail-skins);
+  webRoot = (roundcubemail.override { roundcube_config = "/var/secrets/webapps/tools-roundcube"; }).withPlugins (p: [ p.automatic_addressbook p.carddav p.contextmenu p.contextmenu_folder p.html5_notifier p.ident_switch p.message_highlight p.thunderbird_labels ]);
   apache = rec {
     user = "wwwrun";
     group = "wwwrun";