]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/mail/default.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / mail / default.nix
index ea0a27fc7079f587647bceb3efa160fafc7b7997..634269490b908eb7b35febff418e665ec766f9bc 100644 (file)
@@ -1,8 +1,8 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
   roundcubemail = pkgs.callPackage ./roundcubemail.nix {
     inherit (pkgs.webapps) roundcubemail roundcubemail-plugins roundcubemail-skins;
-    env = myconfig.env.tools.roundcubemail;
+    env = config.myEnv.tools.roundcubemail;
   };
   rainloop = pkgs.callPackage ./rainloop.nix {};
   cfg = config.myServices.websites.tools.email;
@@ -17,6 +17,10 @@ in
   ];
 
   config = lib.mkIf cfg.enable {
+    services.duplyBackup.profiles.mail.excludeFile = ''
+      + ${rainloop.varDir}
+      + ${roundcubemail.varDir}
+      '';
     secrets.keys = roundcubemail.keys;
 
     services.websites.env.tools.modules =