]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/mail/default.nix
Remove duply-backup
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / mail / default.nix
index dda2d45056b89c08ae0e26481ae5bc6be9065906..390f7adb98dd37fcd11f23ededa22ee028b515f7 100644 (file)
@@ -1,10 +1,13 @@
 { lib, pkgs, config,  ... }:
 let
   roundcubemail = pkgs.callPackage ./roundcubemail.nix {
-    inherit (pkgs.webapps) roundcubemail roundcubemail-plugins roundcubemail-skins;
+    inherit (pkgs.webapps) roundcubemail;
     env = config.myEnv.tools.roundcubemail;
+    inherit config;
+  };
+  rainloop = pkgs.callPackage ./rainloop.nix {
+    rainloop = pkgs.rainloop-community;
   };
-  rainloop = pkgs.callPackage ./rainloop.nix {};
   cfg = config.myServices.websites.tools.email;
   pcfg = config.services.phpfpm.pools;
 in
@@ -18,10 +21,6 @@ in
   ];
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.mail.excludeFile = ''
-      + ${rainloop.varDir}
-      + ${roundcubemail.varDir}
-      '';
     secrets.keys = roundcubemail.keys;
 
     services.websites.env.tools.modules =
@@ -33,12 +32,12 @@ in
       certName   = "mail";
       addToCerts = true;
       hosts      = ["mail.immae.eu"];
-      root       = "/run/current-system/webapps/_mail";
+      root       = ./www;
       extraConfig = [
         (rainloop.apache.vhostConf pcfg.rainloop.socket)
         (roundcubemail.apache.vhostConf pcfg.roundcubemail.socket)
         ''
-          <Directory /run/current-system/webapps/_mail>
+          <Directory ${./www}>
             Require all granted
             Options -Indexes
           </Directory>
@@ -60,24 +59,21 @@ in
       user = "wwwrun";
       group = "wwwrun";
       settings = roundcubemail.phpFpm.pool;
-      phpOptions = config.services.phpfpm.phpOptions + roundcubemail.phpFpm.phpConfig;
+      phpOptions = config.services.phpfpm.phpOptions + ''
+        date.timezone = 'CET'
+      '';
+      phpPackage = pkgs.php72.withExtensions({ enabled, all }: enabled ++ [ all.imagick ]);
     };
     services.phpfpm.pools.rainloop = {
       user = "wwwrun";
       group = "wwwrun";
       settings = rainloop.phpFpm.pool;
+      phpPackage = pkgs.php72;
     };
     system.activationScripts = {
       roundcubemail = roundcubemail.activationScript;
       rainloop = rainloop.activationScript;
     };
-
-    services.websites.webappDirs = {
-      _mail = ./www;
-      "${roundcubemail.apache.webappName}" = roundcubemail.webRoot;
-      "${rainloop.apache.webappName}" = rainloop.webRoot;
-    };
-
   };
 
 }