]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/git/default.nix
Upgrade nixos
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / git / default.nix
index d66d15119168b1eed32960dcecee17afe45f3d3e..56e44015c645e32297fb41ac871686450b2c20f1 100644 (file)
@@ -1,8 +1,8 @@
-{ lib, pkgs, config, myconfig, ... }:
+{ lib, pkgs, config, ... }:
 let
     mantisbt = pkgs.callPackage ./mantisbt.nix {
       inherit (pkgs.webapps) mantisbt_2 mantisbt_2-plugins;
-      env = myconfig.env.tools.mantisbt;
+      env = config.myEnv.tools.mantisbt;
     };
     gitweb = pkgs.callPackage ./gitweb.nix {
       gitoliteDir = config.myServices.gitolite.gitoliteDir;
@@ -30,7 +30,7 @@ in {
       root        = gitweb.apache.root;
       extraConfig = [
         gitweb.apache.vhostConf
-        mantisbt.apache.vhostConf
+        (mantisbt.apache.vhostConf config.services.phpfpm.pools.mantisbt.socket)
         ''
           RewriteEngine on
           RewriteCond %{REQUEST_URI}       ^/releases
@@ -38,8 +38,12 @@ in {
           ''
       ];
     };
-    services.phpfpm.poolConfigs = {
-      mantisbt = mantisbt.phpFpm.pool;
+    services.phpfpm.pools = {
+      mantisbt = {
+        user = config.services.httpd.Tools.user;
+        group = config.services.httpd.Tools.group;
+        settings = mantisbt.phpFpm.pool;
+      };
     };
   };
 }