]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/ether/default.nix
Add mypads to etherpad
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / ether / default.nix
index da88ec54bb5c88e69818ceeda28d4237f7fedf1f..a0329ef6f881fe8d85458d5196273e0ea1be2aa6 100644 (file)
@@ -33,6 +33,8 @@ in {
           {
             "title": "Etherpad",
             "favicon": "favicon.ico",
+            "skinName": "colibris",
+            "skinVariants": "dark-toolbar light-background super-light-editor full-width-editor",
 
             "ip": "",
             "port" : "${ecfg.sockets.node}",
@@ -86,7 +88,12 @@ in {
               "percentageToScrollWhenUserPressesArrowUp": 0
             },
             "users": {
+              "admin": {
+                "password": "${env.adminPassword}",
+                "is_admin": true
+              },
               "ldapauth": {
+                "hash": "invalid",
                 "url": "ldaps://${env.ldap.host}",
                 "accountBase": "${env.ldap.base}",
                 "accountPattern": "${env.ldap.filter}",
@@ -101,6 +108,23 @@ in {
                 "anonymousReadonly": false
               }
             },
+            "ep_mypads": {
+              "warning": "This hash is stored in database, changing anything here will not have any consequence",
+              "ldap": {
+                "url": "ldaps://${env.ldap.host}",
+                "bindDN": "${env.ldap.dn}",
+                "bindCredentials": "${env.ldap.password}",
+                "searchBase": "${env.ldap.base}",
+                "searchFilter": "${env.ldap.filter}",
+                "properties": {
+                  "login": "uid",
+                  "email": "mail",
+                  "firstname": "givenName",
+                  "lastname": "sn"
+                },
+                "defaultLang": "fr"
+              }
+            },
             "socketTransportProtocols" : ["xhr-polling", "jsonp-polling", "htmlfile"],
             "loadTest": false,
             "indentationOnNewLine": false,