]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/ether/default.nix
Add mypads to etherpad
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / ether / default.nix
index 50446fffc8a316c96517e656452ab59673e5c449..a0329ef6f881fe8d85458d5196273e0ea1be2aa6 100644 (file)
@@ -88,6 +88,10 @@ in {
               "percentageToScrollWhenUserPressesArrowUp": 0
             },
             "users": {
+              "admin": {
+                "password": "${env.adminPassword}",
+                "is_admin": true
+              },
               "ldapauth": {
                 "hash": "invalid",
                 "url": "ldaps://${env.ldap.host}",
@@ -104,6 +108,23 @@ in {
                 "anonymousReadonly": false
               }
             },
+            "ep_mypads": {
+              "warning": "This hash is stored in database, changing anything here will not have any consequence",
+              "ldap": {
+                "url": "ldaps://${env.ldap.host}",
+                "bindDN": "${env.ldap.dn}",
+                "bindCredentials": "${env.ldap.password}",
+                "searchBase": "${env.ldap.base}",
+                "searchFilter": "${env.ldap.filter}",
+                "properties": {
+                  "login": "uid",
+                  "email": "mail",
+                  "firstname": "givenName",
+                  "lastname": "sn"
+                },
+                "defaultLang": "fr"
+              }
+            },
             "socketTransportProtocols" : ["xhr-polling", "jsonp-polling", "htmlfile"],
             "loadTest": false,
             "indentationOnNewLine": false,