]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/ether/default.nix
Upgrade etherpad-lite
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / ether / default.nix
index 1c56ed7a2fc6ed77f18c6e5a145b12ce425dfda7..50446fffc8a316c96517e656452ab59673e5c449 100644 (file)
@@ -33,6 +33,8 @@ in {
           {
             "title": "Etherpad",
             "favicon": "favicon.ico",
+            "skinName": "colibris",
+            "skinVariants": "dark-toolbar light-background super-light-editor full-width-editor",
 
             "ip": "",
             "port" : "${ecfg.sockets.node}",
@@ -58,7 +60,7 @@ in {
               "rtl": false,
               "alwaysShowChat": false,
               "chatAndUsers": false,
-              "lang": "en-gb"
+              "lang": "fr"
             },
 
             "suppressErrorsInPadText" : false,
@@ -69,7 +71,7 @@ in {
             "maxAge" : 21600,
             "abiword" : null,
             "soffice" : "${libreoffice}/bin/soffice",
-            "tidyHtml" : "${pkgs.html-tidy}/bin/tidy",
+            "tidyHtml" : "",
             "allowUnknownFileEnds" : true,
             "requireAuthentication" : false,
             "requireAuthorization" : false,
@@ -87,6 +89,7 @@ in {
             },
             "users": {
               "ldapauth": {
+                "hash": "invalid",
                 "url": "ldaps://${env.ldap.host}",
                 "accountBase": "${env.ldap.base}",
                 "accountPattern": "${env.ldap.filter}",
@@ -135,6 +138,8 @@ in {
     };
 
     systemd.services.etherpad-lite.serviceConfig.SupplementaryGroups = "keys";
+    # Needed so that they get in the closure
+    systemd.services.etherpad-lite.path = [ libreoffice pkgs.html-tidy ];
 
     services.filesWatcher.etherpad-lite = {
       restart = true;