]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/ether/default.nix
Fix some etherpad-lite modules and packaging
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / ether / default.nix
index 1c56ed7a2fc6ed77f18c6e5a145b12ce425dfda7..3350a4a1bd802599c88d1f4a767d8aba22a99bd1 100644 (file)
@@ -33,6 +33,8 @@ in {
           {
             "title": "Etherpad",
             "favicon": "favicon.ico",
+            "skinName": "colibris",
+            "skinVariants": "dark-toolbar light-background super-light-editor full-width-editor",
 
             "ip": "",
             "port" : "${ecfg.sockets.node}",
@@ -58,7 +60,7 @@ in {
               "rtl": false,
               "alwaysShowChat": false,
               "chatAndUsers": false,
-              "lang": "en-gb"
+              "lang": "fr"
             },
 
             "suppressErrorsInPadText" : false,
@@ -69,7 +71,7 @@ in {
             "maxAge" : 21600,
             "abiword" : null,
             "soffice" : "${libreoffice}/bin/soffice",
-            "tidyHtml" : "${pkgs.html-tidy}/bin/tidy",
+            "tidyHtml" : "",
             "allowUnknownFileEnds" : true,
             "requireAuthentication" : false,
             "requireAuthorization" : false,
@@ -86,7 +88,12 @@ in {
               "percentageToScrollWhenUserPressesArrowUp": 0
             },
             "users": {
+              "admin": {
+                "password": "${env.adminPassword}",
+                "is_admin": true
+              },
               "ldapauth": {
+                "hash": "invalid",
                 "url": "ldaps://${env.ldap.host}",
                 "accountBase": "${env.ldap.base}",
                 "accountPattern": "${env.ldap.filter}",
@@ -101,6 +108,27 @@ in {
                 "anonymousReadonly": false
               }
             },
+            "ep_mypads": {
+              "warning": "This hash is stored in database, changing anything here will not have any consequence",
+              "ldap": {
+                "url": "ldaps://${env.ldap.host}",
+                "bindDN": "${env.ldap.dn}",
+                "bindCredentials": "${env.ldap.password}",
+                "searchBase": "${env.ldap.base}",
+                "searchFilter": "${env.ldap.filter}",
+                "properties": {
+                  "login": "uid",
+                  "email": "mail",
+                  "firstname": "givenName",
+                  "lastname": "sn"
+                },
+                "defaultLang": "fr"
+              }
+            },
+            "ep_comments_page": {
+              "displayCommentAsIcon": true,
+              "highlightSelectedText": true
+            },
             "socketTransportProtocols" : ["xhr-polling", "jsonp-polling", "htmlfile"],
             "loadTest": false,
             "indentationOnNewLine": false,
@@ -128,13 +156,24 @@ in {
     ];
     services.etherpad-lite = {
       enable = true;
-      modules = builtins.attrValues pkgs.webapps.etherpad-lite-modules;
+      package = pkgs.webapps.etherpad-lite.withModules (p: [
+        p.ep_align p.ep_bookmark p.ep_colors p.ep_comments_page
+        p.ep_cursortrace p.ep_delete_empty_pads p.ep_embedmedia
+        p.ep_font_size p.ep_headings2 p.ep_immae_buttons p.ep_ldapauth
+        p.ep_line_height p.ep_markdown p.ep_mypads p.ep_page_view
+        p.ep_previewimages p.ep_ruler p.ep_scrollto
+        p.ep_set_title_on_pad p.ep_subscript_and_superscript
+        p.ep_timesliderdiff
+      ]);
+      modules = [];
       sessionKeyFile = "/var/secrets/webapps/tools-etherpad-sessionkey";
       apiKeyFile = "/var/secrets/webapps/tools-etherpad-apikey";
       configFile = "/var/secrets/webapps/tools-etherpad";
     };
 
     systemd.services.etherpad-lite.serviceConfig.SupplementaryGroups = "keys";
+    # Needed so that they get in the closure
+    systemd.services.etherpad-lite.path = [ libreoffice pkgs.html-tidy ];
 
     services.filesWatcher.etherpad-lite = {
       restart = true;