]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/cloud/default.nix
Move secrets to flakes
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / cloud / default.nix
index 1a422966d0864569b75851d606ecb47942db4e4c..471858a191fa96109d5d141e3779ae9adc68b4af 100644 (file)
@@ -140,7 +140,7 @@ in {
         cd ${nextcloud}
         NEXTCLOUD_CONFIG_DIR="${nextcloud}/config" \
           exec \
-          sudo -u wwwrun ${pkgs.php74}/bin/php \
+          sudo -E -u wwwrun ${pkgs.php74}/bin/php \
           -c ${pkgs.php74}/etc/php.ini \
           occ $*
         '';
@@ -157,7 +157,7 @@ in {
         ${builtins.concatStringsSep "\n" (lib.attrsets.mapAttrsToList (n: v:
           "install -D -m 0644 -o wwwrun -g wwwrun -T ${v} ${varDir}/config/${n}.json"
           ) confs)}
-        #install -D -m 0600 -o wwwrun -g wwwrun -T /var/secrets/webapps/tools-nextcloud ${varDir}/config/config.php
+        #install -D -m 0600 -o wwwrun -g wwwrun -T ${config.secrets.fullPaths."webapps/tools-nextcloud"} ${varDir}/config/config.php
       '';
     };
     # FIXME: add a warning when config.php changes
@@ -180,7 +180,7 @@ in {
           #! ${pkgs.stdenv.shell}
           export LOCALE_ARCHIVE=/run/current-system/sw/lib/locale/locale-archive
           export PATH=/run/wrappers/bin:$PATH
-          ${pkgs.php74}/bin/php -d memory_limit=512M -f ${nextcloud}/cron.php
+          ${pkgs.php74}/bin/php -d memory_limit=2048M -f ${nextcloud}/cron.php
           '';
       in [
         ''