]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/cloud/default.nix
Use templated secrets to avoid having password in the store
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / cloud / default.nix
index e6f8ecb8a1b0e296f38192d919d24fb3280cb06f..1a422966d0864569b75851d606ecb47942db4e4c 100644 (file)
@@ -43,7 +43,6 @@ in {
   };
 
   config = lib.mkIf cfg.enable {
-    # FIXME: find a way to backup the data
     services.websites.env.tools.modules = [ "proxy_fcgi" ];
 
     services.websites.env.tools.vhostConfs.cloud = {
@@ -85,7 +84,7 @@ in {
         include('${nextcloud}/version.php');
         $CONFIG = array (
           // FIXME: change this value when nextcloud starts getting slow
-          'instanceid' => '${env.instance_id}1',
+          'instanceid' => '${env.instance_id}',
           'datadirectory' => '/var/lib/nextcloud/',
           'passwordsalt' => '${env.password_salt}',
           'debug' => false,
@@ -171,7 +170,7 @@ in {
       user = "wwwrun";
       group = "wwwrun";
       settings = phpFpm.pool;
-      phpPackage = pkgs.php74.withExtensions(e: pkgs.php74.enabledExtensions ++ [ e.redis e.apcu e.opcache ]);
+      phpPackage = pkgs.php74.withExtensions({ enabled, all }: enabled ++ [ all.redis all.apcu all.opcache ]);
     };
 
     services.cron = {