]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/tools/cloud/default.nix
Remove webappdirs
[perso/Immae/Config/Nix.git] / modules / private / websites / tools / cloud / default.nix
index fc0aae62f88d7b4597dbaa605ec16bc18914b5e4..44163de71d80d0fb1e9524513acf2442709acbaa 100644 (file)
@@ -8,8 +8,6 @@ let
   ]);
   env = config.myEnv.tools.nextcloud;
   varDir = "/var/lib/nextcloud";
-  webappName = "tools_nextcloud";
-  apacheRoot = "/run/current-system/webapps/${webappName}";
   cfg = config.myServices.websites.tools.cloud;
   phpFpm = rec {
     basedir = builtins.concatStringsSep ":" ([ nextcloud varDir ] ++ nextcloud.apps);
@@ -49,11 +47,11 @@ in {
       certName    = "eldiron";
       addToCerts  = true;
       hosts       = ["cloud.immae.eu" ];
-      root        = apacheRoot;
+      root        = nextcloud;
       extraConfig = [
         ''
           SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
-          <Directory ${apacheRoot}>
+          <Directory ${nextcloud}>
             AcceptPathInfo On
             DirectoryIndex index.php
             Options FollowSymlinks
@@ -159,11 +157,6 @@ in {
         #install -D -m 0600 -o wwwrun -g wwwrun -T ${config.secrets.fullPaths."webapps/tools-nextcloud"} ${varDir}/config/config.php
       '';
     };
-    # FIXME: add a warning when config.php changes
-    system.extraSystemBuilderCmds = ''
-      mkdir -p $out/webapps
-      ln -s ${nextcloud} $out/webapps/${webappName}
-      '';
 
     services.phpfpm.pools.nextcloud = {
       user = "wwwrun";