]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/richie/production.nix
Use attrs for secrets instead of lists
[perso/Immae/Config/Nix.git] / modules / private / websites / richie / production.nix
index 2d85175441abbfebff231b0fa6c225d9cc8877db..3efa9f05833eb11d941c7fa1dcce86b5ab936720 100644 (file)
@@ -29,8 +29,7 @@ in
     services.duplyBackup.profiles.richie_production.remotes = ["eriomem" "ovh"];
     services.webstats.sites = [ { name = "europe-richie.org"; } ];
 
-    secrets.keys = [{
-      dest = "websites/richie/production";
+    secrets.keys."websites/richie/production" = {
       user = apacheUser;
       group = apacheGroup;
       permissions = "0400";
@@ -48,7 +47,7 @@ in
         $smtp_mailer->Auth('${smtp_mailer.user}', '${smtp_mailer.password}');
         ?>
         '';
-    }];
+    };
     services.websites.webappDirs.richie_production = richieSrc;
     system.activationScripts.richie_production = {
       deps = [ "httpd" ];