]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/production.nix
Use attrs for secrets instead of lists
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / production.nix
index 9e64fca7b864c1372c4743d1523cb79aad7dd860..fed5a0fb40fd76701476c371a096f292857cdb2a 100644 (file)
@@ -1,16 +1,23 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
-  secrets = myconfig.env.websites.piedsjaloux.production;
-  app = pkgs.webapps.piedsjaloux.override { environment = secrets.environment; };
+  secrets = config.myEnv.websites.piedsjaloux.production;
+  app = pkgs.callPackage ./app {
+    composerEnv = pkgs.composerEnv.override { php = pkgs.php72; };
+    environment = secrets.environment;
+    varDir = "/var/lib/piedsjaloux_production";
+    secretsPath = config.secrets.fullPaths."websites/piedsjaloux/production";
+  };
   cfg = config.myServices.websites.piedsjaloux.production;
   pcfg = config.services.phpApplication;
+  texlive = pkgs.texlive.combine { inherit (pkgs.texlive) attachfile preprint scheme-small; };
 in {
   options.myServices.websites.piedsjaloux.production.enable = lib.mkEnableOption "enable PiedsJaloux's website in production";
 
   config = lib.mkIf cfg.enable {
-    services.backup.profiles.piedsjaloux_prod.rootDir = app.varDir;
+    services.duplyBackup.profiles.piedsjaloux_production.rootDir = app.varDir;
+    services.duplyBackup.profiles.piedsjaloux_production.remotes = ["eriomem" "ovh"];
     services.webstats.sites = [ { name = "piedsjaloux.fr"; } ];
-    services.phpApplication.apps.piedsjaloux_prod = {
+    services.phpApplication.apps.piedsjaloux_production = {
       websiteEnv = "production";
       httpdUser = config.services.httpd.Prod.user;
       httpdGroup = config.services.httpd.Prod.group;
@@ -24,63 +31,72 @@ in {
         "./bin/console --env=${app.environment} cache:clear --no-warmup"
       ];
       phpOpenbasedir = [ "/tmp" ];
-      phpPool = ''
-        php_admin_value[upload_max_filesize] = 20M
-        php_admin_value[post_max_size] = 20M
-        ;php_admin_flag[log_errors] = on
-        env[PATH] = ${lib.makeBinPath [ pkgs.apg pkgs.unzip ]}
-        pm = dynamic
-        pm.max_children = 20
-        pm.start_servers = 2
-        pm.min_spare_servers = 1
-        pm.max_spare_servers = 3
-      '';
+      phpPool = {
+        "php_admin_value[upload_max_filesize]" = "20M";
+        "php_admin_value[post_max_size]" = "20M";
+        #"php_admin_flag[log_errors]" = "on";
+        "pm" = "dynamic";
+        "pm.max_children" = "20";
+        "pm.start_servers" = "2";
+        "pm.min_spare_servers" = "1";
+        "pm.max_spare_servers" = "3";
+      };
+      phpEnv = {
+        PATH = lib.makeBinPath [
+          pkgs.apg pkgs.unzip
+          # below ones don't need to be in the PATH but they’re used in
+          # secrets
+          pkgs.imagemagick texlive
+        ];
+      };
       phpWatchFiles = [
-        config.secrets.fullPaths."webapps/${app.environment}-piedsjaloux"
+        app.secretsPath
       ];
+      phpPackage = pkgs.php72;
     };
 
-    secrets.keys = [
-      {
-        dest = "webapps/${app.environment}-piedsjaloux";
-        user = config.services.httpd.Prod.user;
-        group = config.services.httpd.Prod.group;
-        permissions = "0400";
-        text = ''
-          # This file is auto-generated during the composer install
-          parameters:
-              database_host: ${secrets.mysql.host}
-              database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.name}
-              database_user: ${secrets.mysql.user}
-              database_password: ${secrets.mysql.password}
-              database_server_version: ${pkgs.mariadb.mysqlVersion}
-              mailer_transport: smtp
-              mailer_host: 127.0.0.1
-              mailer_user: null
-              mailer_password: null
-              secret: ${secrets.secret}
-              pdflatex: "${pkgs.texlive.combine { inherit (pkgs.texlive) attachfile preprint scheme-small; }}/bin/pdflatex"
-          leapt_im:
-              binary_path: ${pkgs.imagemagick}/bin
-        '';
-      }
-    ];
+    secrets.keys."websites/piedsjaloux/production" = {
+      user = config.services.httpd.Prod.user;
+      group = config.services.httpd.Prod.group;
+      permissions = "0400";
+      text = ''
+        # This file is auto-generated during the composer install
+        parameters:
+            database_host: ${secrets.mysql.host}
+            database_port: ${secrets.mysql.port}
+            database_name: ${secrets.mysql.database}
+            database_user: ${secrets.mysql.user}
+            database_password: ${secrets.mysql.password}
+            database_server_version: ${pkgs.mariadb.mysqlVersion}
+            mailer_transport: smtp
+            mailer_host: 127.0.0.1
+            mailer_user: null
+            mailer_password: null
+            secret: ${secrets.secret}
+            pdflatex: "${texlive}/bin/pdflatex"
+        leapt_im:
+            binary_path: ${pkgs.imagemagick}/bin
+      '';
+    };
 
-    services.websites.env.production.vhostConfs.piedsjaloux_prod = {
+    services.websites.env.production.vhostConfs.piedsjaloux_production = {
       certName     = "piedsjaloux";
       certMainHost = "piedsjaloux.fr";
       hosts        = [ "piedsjaloux.fr" "www.piedsjaloux.fr" ];
-      root         = pcfg.webappDirs.piedsjaloux_prod;
+      root         = pcfg.webappDirs.piedsjaloux_production;
       extraConfig  = [
         ''
+        RewriteEngine on
+        RewriteCond "%{HTTP_HOST}" "!^www.piedsjaloux\.fr$" [NC]
+        RewriteRule ^(.+)$ https://www.piedsjaloux.fr$1 [R=302,L]
+
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.piedsjaloux_prod}|fcgi://localhost"
+          SetHandler "proxy:unix:${pcfg.phpListenPaths.piedsjaloux_production}|fcgi://localhost"
         </FilesMatch>
 
         Use Stats piedsjaloux.fr
 
-        <Directory ${pcfg.webappDirs.piedsjaloux_prod}>
+        <Directory ${pcfg.webappDirs.piedsjaloux_production}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted