]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/production.nix
Redirect websites landing pages
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / production.nix
index 9007f1906c2cdc4b332000b4839ebda268b2d86a..e4e29c710d29f2ce242088e8f99ffca17dfeea04 100644 (file)
@@ -1,6 +1,6 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
-  secrets = myconfig.env.websites.piedsjaloux.production;
+  secrets = config.myEnv.websites.piedsjaloux.production;
   app = pkgs.webapps.piedsjaloux.override { environment = secrets.environment; };
   cfg = config.myServices.websites.piedsjaloux.production;
   pcfg = config.services.phpApplication;
@@ -8,6 +8,7 @@ in {
   options.myServices.websites.piedsjaloux.production.enable = lib.mkEnableOption "enable PiedsJaloux's website in production";
 
   config = lib.mkIf cfg.enable {
+    services.duplyBackup.profiles.piedsjaloux_prod.rootDir = app.varDir;
     services.webstats.sites = [ { name = "piedsjaloux.fr"; } ];
     services.phpApplication.apps.piedsjaloux_prod = {
       websiteEnv = "production";
@@ -50,7 +51,7 @@ in {
           parameters:
               database_host: ${secrets.mysql.host}
               database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.name}
+              database_name: ${secrets.mysql.database}
               database_user: ${secrets.mysql.user}
               database_password: ${secrets.mysql.password}
               database_server_version: ${pkgs.mariadb.mysqlVersion}
@@ -73,6 +74,10 @@ in {
       root         = pcfg.webappDirs.piedsjaloux_prod;
       extraConfig  = [
         ''
+        RewriteEngine on
+        RewriteCond "%{HTTP_HOST}" "!^www.piedsjaloux\.fr$" [NC]
+        RewriteRule ^(.+)$ https://www.piedsjaloux.fr$1 [R=302,L]
+
         <FilesMatch "\.php$">
           SetHandler "proxy:unix:${pcfg.phpListenPaths.piedsjaloux_prod}|fcgi://localhost"
         </FilesMatch>