]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/production.nix
Add config for CI
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / production.nix
index fed5a0fb40fd76701476c371a096f292857cdb2a..422c7f091783f37716a69b3f748e9544ee54c466 100644 (file)
@@ -14,8 +14,6 @@ in {
   options.myServices.websites.piedsjaloux.production.enable = lib.mkEnableOption "enable PiedsJaloux's website in production";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.piedsjaloux_production.rootDir = app.varDir;
-    services.duplyBackup.profiles.piedsjaloux_production.remotes = ["eriomem" "ovh"];
     services.webstats.sites = [ { name = "piedsjaloux.fr"; } ];
     services.phpApplication.apps.piedsjaloux_production = {
       websiteEnv = "production";
@@ -83,7 +81,7 @@ in {
       certName     = "piedsjaloux";
       certMainHost = "piedsjaloux.fr";
       hosts        = [ "piedsjaloux.fr" "www.piedsjaloux.fr" ];
-      root         = pcfg.webappDirs.piedsjaloux_production;
+      root         = app.webRoot;
       extraConfig  = [
         ''
         RewriteEngine on
@@ -96,7 +94,7 @@ in {
 
         Use Stats piedsjaloux.fr
 
-        <Directory ${pcfg.webappDirs.piedsjaloux_production}>
+        <Directory ${app.webRoot}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted