]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/production.nix
Add config for CI
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / production.nix
index e12b046fa688331da510a3bd9873b60847047d6d..422c7f091783f37716a69b3f748e9544ee54c466 100644 (file)
@@ -14,8 +14,6 @@ in {
   options.myServices.websites.piedsjaloux.production.enable = lib.mkEnableOption "enable PiedsJaloux's website in production";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.piedsjaloux_production.rootDir = app.varDir;
-    services.duplyBackup.profiles.piedsjaloux_production.remotes = ["eriomem" "ovh"];
     services.webstats.sites = [ { name = "piedsjaloux.fr"; } ];
     services.phpApplication.apps.piedsjaloux_production = {
       websiteEnv = "production";
@@ -55,38 +53,35 @@ in {
       phpPackage = pkgs.php72;
     };
 
-    secrets.keys = [
-      {
-        dest = "websites/piedsjaloux/production";
-        user = config.services.httpd.Prod.user;
-        group = config.services.httpd.Prod.group;
-        permissions = "0400";
-        text = ''
-          # This file is auto-generated during the composer install
-          parameters:
-              database_host: ${secrets.mysql.host}
-              database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.database}
-              database_user: ${secrets.mysql.user}
-              database_password: ${secrets.mysql.password}
-              database_server_version: ${pkgs.mariadb.mysqlVersion}
-              mailer_transport: smtp
-              mailer_host: 127.0.0.1
-              mailer_user: null
-              mailer_password: null
-              secret: ${secrets.secret}
-              pdflatex: "${texlive}/bin/pdflatex"
-          leapt_im:
-              binary_path: ${pkgs.imagemagick}/bin
-        '';
-      }
-    ];
+    secrets.keys."websites/piedsjaloux/production" = {
+      user = config.services.httpd.Prod.user;
+      group = config.services.httpd.Prod.group;
+      permissions = "0400";
+      text = ''
+        # This file is auto-generated during the composer install
+        parameters:
+            database_host: ${secrets.mysql.host}
+            database_port: ${secrets.mysql.port}
+            database_name: ${secrets.mysql.database}
+            database_user: ${secrets.mysql.user}
+            database_password: ${secrets.mysql.password}
+            database_server_version: ${pkgs.mariadb.mysqlVersion}
+            mailer_transport: smtp
+            mailer_host: 127.0.0.1
+            mailer_user: null
+            mailer_password: null
+            secret: ${secrets.secret}
+            pdflatex: "${texlive}/bin/pdflatex"
+        leapt_im:
+            binary_path: ${pkgs.imagemagick}/bin
+      '';
+    };
 
     services.websites.env.production.vhostConfs.piedsjaloux_production = {
       certName     = "piedsjaloux";
       certMainHost = "piedsjaloux.fr";
       hosts        = [ "piedsjaloux.fr" "www.piedsjaloux.fr" ];
-      root         = pcfg.webappDirs.piedsjaloux_production;
+      root         = app.webRoot;
       extraConfig  = [
         ''
         RewriteEngine on
@@ -99,7 +94,7 @@ in {
 
         Use Stats piedsjaloux.fr
 
-        <Directory ${pcfg.webappDirs.piedsjaloux_production}>
+        <Directory ${app.webRoot}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride All
           Require all granted