]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/production.nix
Add specification for the private config file as a module.
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / production.nix
index 2267e03fdefdba3f5496853da3247b34ac36f2cd..28f85eb180474318204000dc6e4004bd00dd1876 100644 (file)
@@ -1,6 +1,6 @@
-{ lib, pkgs, config, myconfig,  ... }:
+{ lib, pkgs, config,  ... }:
 let
-  secrets = myconfig.env.websites.piedsjaloux.production;
+  secrets = config.myEnv.websites.piedsjaloux.production;
   app = pkgs.webapps.piedsjaloux.override { environment = secrets.environment; };
   cfg = config.myServices.websites.piedsjaloux.production;
   pcfg = config.services.phpApplication;
@@ -51,7 +51,7 @@ in {
           parameters:
               database_host: ${secrets.mysql.host}
               database_port: ${secrets.mysql.port}
-              database_name: ${secrets.mysql.name}
+              database_name: ${secrets.mysql.database}
               database_user: ${secrets.mysql.user}
               database_password: ${secrets.mysql.password}
               database_server_version: ${pkgs.mariadb.mysqlVersion}