]> git.immae.eu Git - perso/Immae/Config/Nix.git/blobdiff - modules/private/websites/piedsjaloux/integration.nix
Remove overlay that overrides the php version
[perso/Immae/Config/Nix.git] / modules / private / websites / piedsjaloux / integration.nix
index 5907bc8afe50980ada5139b7bf16647454ff601c..dc98900b036bc6208a9cd400adbd87b630bc60f9 100644 (file)
@@ -1,15 +1,21 @@
 { lib, pkgs, config,  ... }:
 let
   secrets = config.myEnv.websites.piedsjaloux.integration;
-  app = pkgs.webapps.piedsjaloux.override { environment = secrets.environment; };
+  app = pkgs.callPackage ./app {
+    composerEnv = pkgs.composerEnv.override { php = pkgs.php72; };
+    environment = secrets.environment;
+    varDir = "/var/lib/piedsjaloux_integration";
+    secretsPath = config.secrets.fullPaths."websites/piedsjaloux/integration";
+  };
   cfg = config.myServices.websites.piedsjaloux.integration;
   pcfg = config.services.phpApplication;
+  texlive = pkgs.texlive.combine { inherit (pkgs.texlive) attachfile preprint scheme-small; };
 in {
   options.myServices.websites.piedsjaloux.integration.enable = lib.mkEnableOption "enable PiedsJaloux's website in integration";
 
   config = lib.mkIf cfg.enable {
-    services.duplyBackup.profiles.piedsjaloux_dev.rootDir = app.varDir;
-    services.phpApplication.apps.piedsjaloux_dev = {
+    services.duplyBackup.profiles.piedsjaloux_integration.rootDir = app.varDir;
+    services.phpApplication.apps.piedsjaloux_integration = {
       websiteEnv = "integration";
       httpdUser = config.services.httpd.Inte.user;
       httpdGroup = config.services.httpd.Inte.group;
@@ -23,24 +29,32 @@ in {
         "./bin/console --env=${app.environment} cache:clear --no-warmup"
       ];
       phpOpenbasedir = [ "/tmp" ];
-      phpPool = ''
-        php_admin_value[upload_max_filesize] = 20M
-        php_admin_value[post_max_size] = 20M
-        ;php_admin_flag[log_errors] = on
-        env[PATH] = ${lib.makeBinPath [ pkgs.apg pkgs.unzip ]}
-        pm = ondemand
-        pm.max_children = 5
-        pm.process_idle_timeout = 60
-        env[SYMFONY_DEBUG_MODE] = "yes"
-      '';
+      phpPool = {
+        "php_admin_value[upload_max_filesize]" = "20M";
+        "php_admin_value[post_max_size]" = "20M";
+        #"php_admin_flag[log_errors]" = "on";
+        "pm" = "ondemand";
+        "pm.max_children" = "5";
+        "pm.process_idle_timeout" = "60";
+      };
+      phpEnv = {
+        PATH = lib.makeBinPath [
+          pkgs.apg pkgs.unzip
+          # below ones don't need to be in the PATH but they’re used in
+          # secrets
+          pkgs.imagemagick texlive
+        ];
+        SYMFONY_DEBUG_MODE = "\"yes\"";
+      };
       phpWatchFiles = [
-        config.secrets.fullPaths."webapps/${app.environment}-piedsjaloux"
+        app.secretsPath
       ];
+      phpPackage = pkgs.php72;
     };
 
     secrets.keys = [
       {
-        dest = "webapps/${app.environment}-piedsjaloux";
+        dest = "websites/piedsjaloux/integration";
         user = config.services.httpd.Inte.user;
         group = config.services.httpd.Inte.group;
         permissions = "0400";
@@ -58,22 +72,22 @@ in {
               mailer_user: null
               mailer_password: null
               secret: ${secrets.secret}
-              pdflatex: "${pkgs.texlive.combine { inherit (pkgs.texlive) attachfile preprint scheme-small; }}/bin/pdflatex"
+              pdflatex: "${texlive}/bin/pdflatex"
           leapt_im:
               binary_path: ${pkgs.imagemagick}/bin
         '';
       }
     ];
 
-    services.websites.env.integration.vhostConfs.piedsjaloux_dev = {
+    services.websites.env.integration.vhostConfs.piedsjaloux_integration = {
       certName     = "integration";
       addToCerts  = true;
       hosts       = [ "piedsjaloux.immae.eu" ];
-      root        = pcfg.webappDirs.piedsjaloux_dev;
+      root        = pcfg.webappDirs.piedsjaloux_integration;
       extraConfig = [
         ''
         <FilesMatch "\.php$">
-          SetHandler "proxy:unix:${pcfg.phpListenPaths.piedsjaloux_dev}|fcgi://localhost"
+          SetHandler "proxy:unix:${pcfg.phpListenPaths.piedsjaloux_integration}|fcgi://localhost"
         </FilesMatch>
 
         <Location />
@@ -82,7 +96,7 @@ in {
           ErrorDocument 401 "<html><meta http-equiv=\"refresh\" content=\"0;url=https://piedsjaloux.fr\"></html>"
         </Location>
 
-        <Directory ${pcfg.webappDirs.piedsjaloux_dev}>
+        <Directory ${pcfg.webappDirs.piedsjaloux_integration}>
           Options Indexes FollowSymLinks MultiViews Includes
           AllowOverride None
           Require all granted